[Clam-devel] Network Editor, OSX, Jack

Jeff Kearns jdkearns at cox.net
Thu Mar 26 18:19:17 PDT 2009

That's what I thought, so I built my own. The Clam Libs 1.3.0 compiled  
fine, except one needs an older libxerces-c than the current .3.0.1,   
the .27.0 ver worked fine. The other was missing a DOMWriter.hpp file.
The NetworkEditor 1.3 also works, except Scons only builds Unix exe's  
of the apps, which is fine, but for one thing. Prototyper and  
QTDesigner don't find the libCLAMWidgets.dylib  They (the apps) still  
work, but obviously with no widgets in the palette or .ui view.
Scons did build and install them, and I put a copy in local/lib,  
Trolltech/Qt4.4.3/lib, in the build root folder etc. On launch,  
Terminal says:
ibook-2:NetworkEditor-1.3.0 jeff$ ./prototyper
Backend 'jack' selected.
Looking for plugins at path: /usr/local/Trolltech/Qt-4.4.3/plugins/ 
Looking for plugins at path: /Volumes/Media/Dev/NetworkEditor-1.3.0/ 
Looking for plugins at path: /user/share/NetworkEditor/qtplugins
Looking for plugins at path: /Volumes/Media/Dev/NetworkEditor-1.3.0/../ 
plugins     <---  ??
Looking for Oscilloscope widgets...
Looking for Vumeter widgets...
Looking for SpectrumView widgets...
Looking for PeakView widgets...
Looking for CLAM::VM::Tonnetz widgets...
Looking for CLAM::VM::KeySpace widgets...
Looking for CLAM::VM::Spectrogram widgets...
Looking for PolarChromaPeaks widgets...
Looking for CLAM::VM::ChordRanking widgets...
Looking for CLAM::VM::LPModelView widgets...
Looking for CLAM::VM::MelCepstrumView widgets...
Looking for CLAM::VM::MelSpectrumView widgets...
Looking for SegmentationView widgets...
Looking for ProgressControlWidget widgets...
Looking for configuration actions...
I think Scons halfway thinks it was building a Mac app bundle,  
especially after running otool on the binaries. Anyway, reading the  
list archive I recall someone mentioned a script for OSX to fix-libs ?  
Probably a change_install_name routine? I tried to run that tool once  
after another Scons build (of Hydrogen) but am not sure if that would  
help. Or a dylid_lib_path var declared on execution?
Only thing I might try is to recompile and install all in one step.  
When I built NE I ran scons and then checked out the output in the  
build dir before running scons install. It was the second step where  
the widgets got built, so maybe the binary didn't get linked to the  
dylib. Scons is rather hard to follow for me.
Any ideas?
Thanks, JK

On Mar 24, 2009, at 3:31 PM, Pau Arumí wrote:

> It looks like the .dmg has been compiled without jack support. Yes, it
> should be possible to build on a PPC, though it has been a long time
> since the last time maintainers did it.
> Find some aids at the wiki:
> http://clam-project.org/wiki/Devel/Mac_OSX_build

More information about the clam-devel mailing list