[CLAM] 0.90pre2 build error

L M mailars at gmail.com
Fri Dec 16 06:08:11 PST 2005


I tried building the latest pre2-release here on Fedora 3
(ccrma-distro), but get this error:

g++ -O2 -fomit-frame-pointer -Wall -O2 -march=i386 -mcpu=i686 -include
-DUSE_GL=1 -DUSE_FLTK=1 -Ivmfl/include -Icore/include
-Iprocessing/include -Iaudioio/include -I/usr/lib/qt-3.3/include
-I/usr/local/include -I/usr/X11R6/include -c -o
vmfl/src/WidgetTKWrapper.os vmfl/src/WidgetTKWrapper.cxx
In file included from vmfl/src/WidgetTKWrapper.cxx:24:
processing/include/CLAM/SupportedToolkits.hxx:26:27: FLTKWrapper.hxx:
No such file or directory
vmfl/src/WidgetTKWrapper.cxx: In static member function `static
CLAMVM::WidgetTKWrapper& CLAMVM::WidgetTKWrapper::GetWrapperFor(const
vmfl/src/WidgetTKWrapper.cxx:43: error: `FLTKWrapper' has not been declared
vmfl/src/WidgetTKWrapper.cxx:43: error: `GetInstance' undeclared
(first use this function)
vmfl/src/WidgetTKWrapper.cxx:43: error: (Each undeclared identifier is
reported only once for each function it appears in.)
scons: *** [vmfl/src/WidgetTKWrapper.os] Error 1
scons: building terminated because of errors.

Seems some file is missing?

Before that I had 2 other minor problems:

1. When I started scons in scons/libs/, it first complained about some
dmg module:
$ scons
scons: Reading SConscript files ...
ImportError: No module named dmg_creation:
  File "SConstruct", line 13:
    from buildtools.dmg_creation import *

.. which could be resolved by commenting the corresponding line in the

2. Then I got an error about missing qt_includes:

$ scons
scons: Reading SConscript files ...

scons: *** Path does not exist for option qt_includes: /usr/include/qt3
File "SConstruct", line 84, in setup_build_options

... which on my system is in reality in /usr/lib/qt-3.3/include . A
symlink solved that problem.


Lars Mai

More information about the clam-users mailing list