[CLAM] Alsa Error trying to run the "simple Network Example"

David Garcia Garzon david.garcia at barcelonamedia.org
Sat Aug 20 03:09:01 PDT 2011

Did you install from binary packages or source tarballs at a given version or did you install from subversion?

In order, for you to keep working i would try with the JACKNetworkPlayer backend instead the PANetworkPlayer backend, since the former is more tested. Anyway we should fix any problem we find with the PA backend so it would be great if you help us to  locate the problem.

It looks to come from the configuration of alsa as it complaints about the samplerate. I see in the Which is the default sampling rate your card works with? Do you have any problem on working with 44100? 


De: clam-users-bounces at lists.clam-project.org [clam-users-bounces at lists.clam-project.org] En nom de Daniela Choquet [fh at daniela-choquet.de]
Enviat el: dilluns, 8 / agost / 2011 10:08
Per a: clam-users at lists.clam-project.org
Tema: [CLAM] Alsa Error trying to run the "simple Network Example"


Maybe someone can help me. I installed the libs and the networkeditor. If I run
a .clamnetwork File in the NetworkEditor and connect the output of the Editor
with the System in Jack, there is no error.

If I import the same .clamnetwork file in my code using the Example to run a
simple network file from the homepage (the
http://clam-project.org/wiki/Loading_and_playing_a_simple_network Example, no
changes and Build with the SConstruct from the homepage runs through without
errors) it shows ALSA errors when running und aborts:

ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dsnoop.c:612:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only
playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Portaudio Chosen API: ALSA 0
PortAudio: Chosen Output: HDA ATI HDMI: HDMI 0 (hw:1,3)
Expression 'SetApproximateSampleRate( pcm, hwParams, sr )' failed in
'src/hostapi/alsa/pa_linux_alsa.c', line: 1964
Expression 'PaAlsaStreamComponent_InitialConfigure( &self->playback, outParams,
self->primeBuffers, hwParamsPlayback, &realSr )' failed in
'src/hostapi/alsa/pa_linux_alsa.c', line: 2642
Expression 'PaAlsaStream_Configure( stream, inputParameters, outputParameters,
sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode
)' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2763
PortAudio Error #-9997: Invalid sample rate
Default API 0
* ALSA (0)
         (0/0)   *>  *>HDA ATI HDMI: HDMI 0 (hw:1,3) Inputs: 0 Outputs: 2
  OSS (1)
  JACK Audio Connection Kit (2)
         (1/0)     *<*>system Inputs: 2 Outputs: 4
  skeleton implementation (3)

My Guess is, that it is an problem with the configuration of Jack. But I dont
know what it is exactly or how to fix it.

Maybe the following has something todo with it:
In the NetworkEditor, I have the Problem, that Jack (the GUI Frontend qJackCtl)
cant see the NetworkEditor-Output since I have started to run the Network for
the first time. When I run my own application in Eclipse, I cant see any Output
at all, so I cant connect anything...

Has someone an Idea?
Thanks for help in advance!

clam-users mailing list
clam-users at lists.clam-project.org

More information about the clam-users mailing list