[Clam-devel] IMPORTANT: more changes to build system

Pau Arumi parumi at iua.upf.edu
Wed May 23 00:14:34 PDT 2007

Hernán Ordiales wrote:
> On 5/17/07, Pau Arumi <parumi at iua.upf.edu> wrote:
>> En/na David García Garzón ha escrit:
>> > so the complete list of prefix* options on libs and applications is...
> hi all,
> seems that something is broken with distcc compilation since lasts
> 'SConstruct' updates:
> when i compile with something like: " scons distcc_hosts='localhost
> anothercomputer' " i get an error like this:
> checking for C++ header file xercesc/util/PlatformUtils.hpp... no
> Could not find xerces c headers! Defaulting to the null xml backend
> not worry xerces dev package is correctly installed, indeed with "
> scons distcc_hosts='' " compiles without problems, then the problems
> seems here:
> (about line 144)
> if clam_env['distcc_hosts'] :
>     clam_env['CXX'] = 'distcc g++'
>     clam_env['ENV']['DISTCC_HOSTS'] = clam_env['distcc_hosts']
>     SetOption('num_jobs', len( clam_env['distcc_hosts'].split() ))
> more precisely with this line: " clam_env['CXX'] = 'distcc g++' "
> I tried to solve it but I have not been able to do it yet. I know this
> kind of things are not high rated on priority lists but maybe any of
> you can give me a clue of why that stoped working and how could be
> related with new changes.

this issue probably shows up now just because now on every "scons
option=value" invocaton, the configure step is automatically
called (which, btw, i a *very* convenient change).

i tried this here and got the same error. looking at config.log
file i saw that xercesc check was the first one using g++ 
(instead of gcc) and, thus, was using "distcc g++". the error was
simple: could not found "distcc". then i installed distcc and all
configure went fine. so, hernan, check if this is also your case.

so now the TODO is: adding a custom distcc checking. i've filled
a bug for that (#262). patches are welcomed!


More information about the clam-devel mailing list