[Clam-devel] re: refactoring backends (2)

dirk.griffioen dirk.griffioen at barcelonamedia.org
Tue Jun 9 01:09:17 PDT 2009

> But, of course, if this implies a change in the user code, in something that 
> is as ubiquitous as CLAM_ASSERT, that's not a solution unless it pays the 
> price.

What if I rename ENFORCE to CLAM_ASSERT_MSG?

You get lines like:

	CLAM_ASSERT_MSG(jack_client_close(jackClient) == 0) ("JACK_ERROR: cannot close client");

Or should there be a tighter fit to the current CLAM_ASSERT?

(For the record, I am not proposing to redo all, just start small by using this where applicable).


More information about the clam-devel mailing list