[CLAM] fftw library (double precision) not found

Albert Mora amora at iua.upf.es
Fri May 23 05:28:38 PDT 2003

Hi, can you send us the configure log and the path where you execute this?


On Sun, 18 May 2003, Albert Mora wrote:
> On Sat, 17 May 2003, Vegard Sandvold wrote:
> > OK, but which version of FFTW do I install? Version 3 is, as I said
> > previously, incompatible with version 2. Which one is compatible with
> > CLAM?
> since we are very interested in the -new- 3.0 version, we use (here I have
> 2.1.3) 2 version...

Hello again!
I have been trying some more, without much success. This is so far I
have come.

I downloaded the source for FFTW version 2.1.5
(ftp://ftp.fftw.org/pub/fftw/fftw-2.1.5.tar.gz) and built and installed
it under the same directory as CLAM/, fltk/ and xercesc/ (I don't have
root access to the computers).

The library files are now contained in:
$ ls fftw-2.1.5/lib/
libfftw.a   libfftw.so    libfftw.so.2.0.7  librfftw.la  librfftw.so.2
libfftw.la  libfftw.so.2  librfftw.a        librfftw.so  librfftw.so.2.0.7

and the C header files in:
$ ls fftw-2.1.5/include/
fftw.h  rfftw.h

They all contain the function 'fftw_sizeof_fftw_real'. I then perform
$ export LD_LIBRARY_PATH=`pwd`/fltk/lib:`pwd`/xercesc/lib:`pwd`/fftw-2.1.5/lib:

When I run ./configure again, the same error occurs. How does CLAM
determine the existence of FFTW libraries?


Albert J. MORA - MTG / IUA / UPF - PLUG
phone: +34 93542.2199
email: amora at iua.upf.es
wpage: http://www.iua.upf.es/~amora

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.clam-project.org/pipermail/clam-users-clam-project.org/attachments/20030523/72f8466f/attachment.sig>

More information about the clam-users mailing list