[CLAM] fftw and configure

Rhywek rhywek at o2.pl
Mon Jul 4 07:42:57 PDT 2005

Hi, CLAM developers.

I just wanted to use CLAM, but I have some problems. I have
installed all the dependencies of CLAM and then I entered the
"CLAM_DIR/build/srcdeps" and executed "make". Then I entered
"CLAM_DIR/build" and executed "autoconf -f && ./configure" and here
is where my problems started.

First I tried that with CLAM-0.8.0-pre2 and the table at the end
showed only ogg vorbis success and failure for all other CLAM
dependencies. So I started investigation about the first one, fftw.
After reading the "CLAM_DIR/build/configure" script I found out that
it needs "fftw.h" file and I did not have it on my system. So I
figured out that newest version of fftw is not compatible with the
one CLAM uses (all what I write about I tested with both 0.7.0 and

Then I tried many different options: First I downloaded the fftw
available at CLAM download page 2.1.5 for redhat (I use fedora core
3 for this). Strangely, after unpacking there are some files in lib,
but they were not detected by the configure script. I had to make a
symbolic link "libfftw.so -> libfftw.so.2.0.7" for one library to be
detected, but still there is nothing like librfftw, which seems also
necessary. So the script shows (after linking):

checking fftw.h for fftw in sandbox... yes
checking fftw header(s) found in sandbox... yes
checking libfftw for fftw in sandbox... yes
checking librfftw for fftw in sandbox... no
checking all fftw lib(s) found in sandbox... no

Now this is about sandbox, but the bigger problem is to get all
those files in my system default places. After version 3.x I
downloaded fftw-2.1.5.tar.gz from fftw.org and executed
"./configure", "make" and "make install", but it did not help --
still during "./configure" in CLAM's build directory it does not
pass the test of compiling the fftw example.

Next I read in the documentation that both single and double
precision fftw is neede, so I did what they say on fftw.org:

./configure --enable-type-prefix [ other options ]
make install
make clean
./configure --enable-float --enable-type-prefix [ other options ]
make install

But still CLAM's ./configure was failing.

As the last resort I found some rpm for fedora:
"ftw-2.1.5-5.i386.rpm" and installed it with "rpm -i
ftw-2.1.5-5.i386.rpm", but this did not help either.

Still both CLAM versions fail during ./configure, the only
difference is that the 0.7.0 stops at fftw and 0.8.0-pre2 goes
through all of the dependencies even if some fails.

Could someone tell me what would be the proper way of getting fftw
installed? Why if I extract the fftw tarball from CLAM website I
still need to make some links that are not mentioned in any manual?
What am I doing wrong?

I've been sitting several days with that problem now and I am close
to give up. Is there some 'best way' of getting CLAM installed? Does
someone have some snapshot of a system that I could just chroot or
something and it would be installed (but I still prefer to install
it myself)? Or maybe AGNULA has CLAM installed by default?

Do I need to execute 'autoconf -f' before every './configure', or not?

I would very much appreciate any help.


I might do something more that I didn't mention, these are just the
steps I am pretty sure of.

More information about the clam-users mailing list