[CLAM] Re: CLAM: Compile problem with fftw

Gregor van den Boogaart gregor.boogaart at informatik.uni-augsburg.de
Tue Oct 31 06:25:25 PST 2006

Hi David!

>> I'm trying to install CLAM and get into problems with mit fftw
>> installation.
> So, the solution to your problem: Install fftw 2 instead. There are some packages available on the standard OpenSuSe package repository. So you should be able install it just by using YaST.
> http://download.opensuse.org/distribution/SL-10.1/inst-source/suse/i586/fftw-2.1.5-17.i586.rpm
> http://download.opensuse.org/distribution/SL-10.1/inst-source/suse/i586/fftw-devel-2.1.5-17.i586.rpm
Using fftw 2, I got around this problem. :-) Now I've found a new one,
regarding id3. :-( Nevertheless I have installed id3, CLAM is not able
to link against it. I'm not shure, whether that's a problem of id3,
ldconfig or CLAM itself. After installing id3, I've got in /usr/lib
(from the distribution) and in /usr/local/lib (installed manually) the
lrwxrwxrwx 1 root root       9 2006-10-31 12:01 libid3-3.8.so.3 -> libid3.so
-rwxr-xr-x 1 root root 1723835 2006-10-31 11:43 libid3-3.8.so.3.0.0
lrwxrwxrwx 1 root root      19 2006-10-31 12:01 libid3.so ->
lrwxrwxrwx 1 root root      18 2006-10-31 11:43 libid3tag.so ->
lrwxrwxrwx 1 root root      18 2006-10-31 11:43 libid3tag.so.0 ->
-rwxr-xr-x 1 root root  179176 2006-10-31 11:43 libid3tag.so.0.3.0

That is libid3.so is only a link and not a shared object itself. Well,
that shouldn't be a difference. Nevertheless ldconfig does not recognize
(?) it. From "ldconfig -p | grep id3" I get:
        libid3tag.so.0 (libc6) => /usr/local/lib/libid3tag.so.0
        libid3tag.so.0 (libc6) => /usr/lib/libid3tag.so.0
        libid3tag.so (libc6) => /usr/local/lib/libid3tag.so
        libid3tag.so (libc6) => /usr/lib/libid3tag.so
        libid3-3.8.so.3 (libc6) => /usr/local/lib/libid3-3.8.so.3
        libid3-3.8.so.3 (libc6) => /usr/lib/libid3-3.8.so.3
I tried everything: replacing the link with a real file and many other
things. ldconfig ignores libid3.so. Consequently the library is not
found during "scons configure":
Checking for C header file mad.h... yes
Checking for mad_stream_init() in C library mad... yes
Checking that libmad sample program compiles...ok
Checking that libmad sample program links...ok
Checking that libmad sample program runs... ok
Checking for C++ header file id3.h... no
Could not find id3lib headers! Please check your id3lib installation

As I could not fix the installation I also tried "scons configure
with_id3=no". Configure finishes well, but compilation is aborted with:
== Copying and updating includes : audioio/src/MpegCodec.cxx
g++ -O2 -fomit-frame-pointer -Wall -fPIC -DCLAM_FLOAT -DUSE_PTHREADS=1
-DUSE_JACK=1 -DCLAM_MODULE='"audioio"' -Iaudioio/include -Icore/include
-Iprocessing/include -I/usr/lib/qt3/include -I/usr/local/include -c -o
audioio/src/MpegCodec.os audioio/src/MpegCodec.cxx
audioio/src/MpegCodec.cxx:27:2: error: #error USE_ID3 was not set to 1
in your settings.cfg file, but you are including files that require
this. Please fix your settings.cfg
scons: *** [audioio/src/MpegCodec.os] Error 1
scons: building terminated because of errors.

Any suggestions?

> BTW, the CLAM features shown on the ACM-MM demo and on the development
> screenshots have been not published yet. So if you are looking for them,
> please don't get dissapointed ;-) We can publish a development source
> snapshot if you want to try it.

It's not in the recent development snapshots on
http://clam.iua.upf.edu/download/src/cvssnapshots/ ??? Well, in this
case I would really appreciate to get access to a current version.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the clam-users mailing list