[CLAM] building on windows.

David García Garzón dgarcia at iua.upf.edu
Fri Sep 28 09:28:52 PDT 2007

After having a lot of problems trying to have a reproducible VisualC 
environment, we dropped VC support in CLAM version 1.1, in favor of mingw. In 
fact, one of the reasons was that we were having problem with the static 
objects we use to intitialize processings factory. They should be working 
perfectly with wine. To my suprise you seem to have the same problem (not 
being able to create some processing types) with precompiled 1.1.0 version of 
the NetEditor available on the web which was already compiled with mingw.

We are currently moving to a new office. So we can not test the binaries to 
check what's happening. Just to be sure, try one of the latest svnsnapshots 

I just tested the latest snapshot under wine (windows emulation under linux) 
and the creation of processing modules worked pretty well.

About the compilations errors you say, it is better that you copy and paste 
them so we can tell you something about them. If you did modifications to the 
source code to get it compiled we would be glad if you send them to the list. 


El Friday 28 September 2007 08:26:58 Ali-Akber Saifee va escriure:
> Hi there.
> I'm looking at using CLAM for a project that my team is looking at. We're
> hoping to create a platform independent solution - but our primary
> expertise lies in Windows development, therefore we're hoping to create a
> working prototype on windows first.
> So here lies my problem :
> My dev environment contains:
> - Windows SDK ( v6 )
> - Visual Studio 2008
> - DirectX 10 SDK.
> Clam source 1.1.0
> Using the above + the dependencies claimed by CLAM  - I set up the scons
> build environment and immediately ran into problems.
> Problem 1 : scons configure fails on id3lib. looking into the
> config.logfile, it shows a few linking errors. I hacked around and
> using updated
> id3lib binaries (recompiled using VS2008) I got that error to subside.
> Subsequently, I got as far as doing a scons - which ended up in compile
> time errors with CLAM src's - having mostly to do with 'default int'
> declarations etc. After hacking around with the CLAM src's I finally got it
> to build - only to realise that every time I tried to build an example I
> got more linking errors.
> Problem 2: When I install the NetworkEditor using the installer (1.1.0) if
> I try to add any of the Audio I/O processings I get an error message
> similar to 'The processing type 'MonoAudioFileReader' is not supported'.
> When trying to use the same processing using the clam libs that I had built
> in 'Problem 1' I was getting similar errors (Processing not enumerated
> etc).
> Right now, I'll try to check out a svn snapshot of 1.2 and see if that
> helps any, but if anyone else has had similar experiences - or resolved
> similar problems - I would love to hear. I'm trying to rapidly develop a
> prototype - and not being able to get into CLAM's entry point is quite
> frustrating :D
> ./Ali

More information about the clam-users mailing list