[CLAM] patch for g++3.4 (was : Mysterious compilation errors)

Pau Arumi parumi at iua.upf.es
Thu May 19 09:45:33 PDT 2005

Attached you'll find the patch to make clam  compile with g++3.4  
(thanks David !)
We have tried it in the clam version in cvs but it will hopefully also 
work on clam 0.7.
Note that it needs to be applied being into the CLAM/src directory

Please tell us if it works for you


Pau Arumi wrote:

> You are right David. At Linux Audio Conference I tried to compile CLAM 
> (in Yann Orlarey laptop) with a gcc 3.4 and we run into these exact 
> problems.
> Then we managed to fix it quite easily but, alas, I did not save the 
> changes so we'll have to do it again.  I'll try to get the patch for 
> ready for tomorrow
> BTW, we are expecting to release CLAM 0.8 next week.
> Best regards
> Pau
> David Garcia Garzon wrote:
>> Firstly we are using gcc 3.3.5. Maybe there is some C++ standard 
>> addons on gcc 3.4.3 that could make our namespace usage obsolete. Try 
>> to compile some plain application (build/Examples/Simple/Configurator 
>> is one that is fast to compile and uses this header for sure). If it 
>> fails, then the problem is a new way of dealling namespaces and 
>> template specializations in gcc 3.4 and it would be nice if you can 
>> give us some feedback to solve this.
>> But, if it works it should be due to any inclusions or using 
>> directive you do before CLAM inclusions. Maybe moving CLAM includes 
>> before your project includes and any 'using' directive, and removing 
>> 'using' directives out of any header could help.
>> David.
>> A Dijous 19 Maig 2005 12:16, Vegard Sandvold va escriure:
>>> Hi,
>>> this seems to be my week of assorted CLAM issues, this time on Linux.
>>> I have configure CLAM-0.7.0 on my Fedora Core 3/PlanetCCRMA machine, 
>>> using
>>> a 2.6.10-2.1.ll.rhfc3.ccrma kernel and gcc (GCC) 3.4.3 20050227 (Red 
>>> Hat
>>> 3.4.3-22.fc3) compiler. Specifically, I configured without qwt, 
>>> portmidi
>>> and portaudio.
>>> When I try to compile my app, I get bucket loads of the following 
>>> kind of
>>> errors:
>>> /usr/local/src/CLAM-0.7.0/src/Defines/TypeInfo.hxx:61: error: extra
>>> qualification ignored
>>> /usr/local/src/CLAM-0.7.0/src/Defines/TypeInfo.hxx:61: error: explicit
>>> specialization of non-template `CLAM::<anonymous class>'
>>> /usr/local/src/CLAM-0.7.0/src/Defines/TypeInfo.hxx:61: error: abstract
>>> declarator `CLAM::<anonymous class>' used as declaration
>>> Seems unlikely that there is something fundamentaly wrong with CLAM. 
>>> Can
>>> there be anything wrong with my setup?
>>> Vegard   
> _______________________________________________
> CLAM mailing list
> CLAM at iua.upf.es
> http://www.iua.upf.es/mtg/clam

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: g++3.4patch
URL: <http://lists.clam-project.org/pipermail/clam-users-clam-project.org/attachments/20050519/b21005fc/attachment.ksh>

More information about the clam-users mailing list